Okta RADIUS Server Agent CVE-2021-44228

Description

Apache Log4j2 <=2.14.1, as used in Okta RADIUS Server Agent prior to 2.17.0, does not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers.

Affected product and versions

Okta RADIUS Server Agent 2.16.0 and earlier

Resolution

The vulnerability is fixed in Okta RADIUS Server Agent version 2.17.0. To remediate this vulnerability, upgrade Okta RADIUS Server Agent.