Okta On-Prem MFA Agent CVE-2021-44228

Description

Apache Log4j2 <=2.14.1, as used in Okta On-Prem MFA Agent (formerly Okta RSA SecurID Agent)  prior to 1.4.6, does not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers.

Affected product and versions

Okta On-Prem MFA Agent (formerly Okta RSA SecurID Agent) 1.4.5 and earlier

Resolution

The vulnerability is fixed in Okta On-Prem MFA Agent (formerly Okta RSA SecurID Agent) version 1.4.6.  To remediate this vulnerability, upgrade Okta On-Prem MFA Agent.